首页头条网红跨境零售品牌物流金融点评 WAP版设为首页
首页 / 头条资讯 / 正文

原因为JRE版本过低unsupported major.minor versio

来源:电商世界
作者:体育小编
时间:2020-09-08

我们在Eclipse或者其他IDE中运行Java工程时,有时会遇到如下问题 :
       java.lang.UnsupportedClassVersionError: 运行的具体类 : Unsupported major.minor version 52.0 (具体版本号,这里可以为其他数值......)这个问题的根本原因是我们使用低版本的 JRE 去运行高版本 JDK 编译的 class 文件!当改变了jdk版本时,在编译java时,会遇到Unsupported major.minor version错误。


解决办法:
       1、先查看项目中的jdk版本。
       2、因为是spring的错误,可以查看jdk版本与spring版本的兼容问题。
出现这个问题的原因是:将高版本JDK编译的项目放到低版本JDK所在的eclipse环境中编译运行将会出现这个错误。因此,要想这个项目在低版本的环境中能够正常运行,可以按照下面的思路进行解决:
       (1)查看JDK的环境变量,确保JDK环境变量已经配置正确
       (2)修改Java Build Path:在eclipse中的项目上鼠标右键,Properties –> Java Build Path –>Libraries,将这里面不存在的删掉,并重新选择当前存在的库,如:JDK1.7、Tomcat7.0等

0
(查看全部0条评论)文明上网理性发言,请遵守新闻评论服务协议!
    
验证码:    
产业点评更多
热点推荐更多
  • 资讯内容纠错答疑在线联系方式
  • Email:894204689@qq.com
  • CopyRight@2015-2020 电商世界 All Right Reserved
  • 工商营业注册:MA4QTWHP-6
  • 工信备案号:湘ICP备19023244号